ERC223 contract compatibility with solidity 0.5.0


#1

Solidity 0.5.0 broke the compatibility with the ERC223 contract, since it disallows the use of ‘constant’, so I was wondering if an updated version of the contract exists, or is the best way to just interface the old contract, as is recommended here: Solidity 0.5.0 breaking changes - interoperability with older contracts, or maybe even using an older version of the solidity compiler?


#2

I know for our tutorial to make an ERC223 token on ETC the compiler version is Solidity 0.4.24 but I think this also has to do with older versions of Solidity compiler working better with Ethereum Classic.

Not sure what to suggest here, maybe @Neuron or @Magistocrat may have the answer for you.


#3

I have only gotten up to Solidity 0.4.21 to work on ETC, and some even say 0.4.19 is the safest.