Issue trading with metamask

Do you mean that currently i can’t use metamask instead of saturn-wallet, can i?
I have no a saturn wallet yet, never had it. 3-4 months ago i used exactly metamask in order to connect to this exchange. Then i didn’t login within a long while, may be i missed some news here.
So, how is it now? Can i use metamask for a login to exchange? If yes, how can i do? Seems it doesn’t work.

Hey @Stock999A no there has not been any changes, I do not usually use MetaMask myself as it does not support ETC. However, to double check I just tried it out and was able to trade fine.

Could you try clearing your browser cache? We have made several website updates if the last time you used the exchange was 3 to 4 months ago. Maybe that is the issue.

When you open an orderbook do you see the orders?


My browser is configured to clean cache&cookies after each session. Well, i cleaned them once again by button. But it was not helpful, it’s still the same.
Seems like your site doesn’t see my metamask, meanwhile it’s running and switched exactly to the ETH address which i have used earlier for this exchange.
I see order book, but there is only one option “buy” (see at the pic. below). But i don’t want to buy anything, i want just remove my sale order and withdraw my tokens. There are no such buttons as ‘withdraw’ or ‘remove’. Also i don’t see something like a history of my orders, or something like my dashboard. That’s why i concluded that metamask is still disconnected to your site, i.t. i am not logged in.

So, what else can i do to fix this? How to remove my order ( the top one on the picture)?
I use metamask version 6.7.2, is it ok?

Metamask version 6.7.2 is working fine for me. If you are logged into your wallet correctly then on the right you would see a “My Orders” section. It would look like so:


In the My Orders section is where you will find the cancel order button. It appears something has gone wrong with your browser or metamask installation, I would try backing up all your wallets (seed phrase and private keys if needed) and reinstalling MetaMask.

Alternatively, install a different dApp browser such as Saturn Wallet, Nifty Wallet on a different browser or Trust on mobile and import your wallet address there.


For a guaranteed result I would

  1. backup the seed phrase from your metamask
  2. download a fresh browser that you don’t normally use, e.g. if you normally use chrome then download firefox. or try the chromium-based vivaldi
  3. install saturn wallet in this new browser. select firefox icon for firefox and chrome icon for every other browser
  4. import seed phrase from step 1 into saturn wallet

Should work!

I just did what was recommended above and it worked! Thank you ! Finally, I can do the things I love! I really love my job, I always wanted to become successful trading. It wasn’t easy at all, I’ve been working hard to achieve it, but it paid off. Now I am earning a lof of money on Investous, and I keep growing. This is fantastic, I am sure that I have a very big potential. I will become a full-time trader soon, and I am so happy about that ! Wish me luck! However, you know what ? I don’t need it. I am confident in my skills.

1 Like

Normally just removing and re-installing Metmask does it for me.

1 Like