Problem sending Titan token


#1

A issue lays with Titan Coin, I can not move whole amounts like 1000, 2000, 3000 Titans. When I open up Saturn Wallet click token, send, enter in the address and amount then cllick Send. The wheel’s just keep spinning without progressing to the gas & send page.
Then another thing I found out with Titan, If I enter in amounts between the numbers I posted above it works. But then another issue happens, so twice I sent large amounts of Titan it ended up sending a total of 0.000000000000000003 Titan instead.


Troubleshoot
#2

Seems very odd that it is only happening for one token, could you first try backing up your wallets & using a fresh Saturn Wallet install? I recommend giving it a go with Brave Browser: Installing Saturn Wallet on Brave Browser?

@BitUnits have you had any reports of people having trouble sending Titan token?


#3

I did a fresh install with wallet on Brave. I first tried again moving 1000 tokens it did not work again (I tried this a few times). 100 & 999 worked but some other tx’s only movied 1/18 of a token, idk.I eventually got them moved though…


#4

No, this is the first time hearing about this issue. I will look into it. thanks for letting me know.


#5

@CryptoOregon next time you need to send them could you maybe try using MEW or Trust Wallet? Then we can confirm if it is an issue with the token or Saturn Wallet. Thanks!