Problem with airdrop tool

trying to make an airdrop using free airdrop tool but i am having this issue
Unable to fetch token information for ‘0x5313E18463Cf2F4b68b392a5b11f94dE5528D01d’. Please ensure you entered correct token address and try again.
thank you

need support please ?

Occasionally that does happen you may just have been unlucky, normally I just enter the token contract address again and it works. Make sure you have not accidently pasted a space into the commandline, and avoid using capital’s, so enter it like so:

0x5313e18463cf2f4b68b392a5b11f94de5528d01d

You can also try copying the tool from our Github and running it locally without using npx:

If you are having trouble we offer marketing services to do this for you, you can learn more below.

Thanks!

same issue !!

Looks like it would work fine for me, what setup are you using it on? Maybe you have not installed node.js correctly? Is your ULLU in the wallet?

i have ullu in my wallet and i start getting this issue :
You do not have any ULLU in your wallet.
what nodejs version is adviced for ?

I’m using v10.19.0 and usually run the tool on Ubuntu.

actually i dont think its a problem related to operating system , i tried to print my ether balance . it shows 0 but actually i have ether in my account

still having the issue

Yep, we have not forgot and looking into this. Thanks!

So the problem is that the public cloudflare ETH RPC endpoint seems to no longer be working:

You will need to set up your own endpoint to use the tool, you can do that for free on https://infura.io/, just register an account and create your first project. You will find your project’s RPC url in the settings section, copy the https one as you will need it.

Download the airdrop-tool locally with this command:

npm install @saturnnetwork/airdrop

Now you need to edit the network.js file to set your infurl url RPC endpoint, if you on linux you could do:

nano node_modules/@saturnnetwork/airdrop/src/networks.js

Once you have replaced the cloudfare endpoint with your own and the network.js file is saved, you can launch airdrop tool locally with:

node node_modules/@saturnnetwork/airdrop/

And you should be good to go!

ok good i’ll try it , i think ethers module gives a default provider with no limit, you should take a look at it

1 Like