Remix IDE - JSON-RPC Error with ETC Network


#1

Hey there everyone, I’m hoping I can find some help.

For the past 4 days, I have been trying to deploy my contract to the ETC Network - but it has continually failed.
When I first installed and setup Saturn Wallet, I was able to deploy a contract to the ETC Network, without any issues. Since then, however, I have continually gotten a “JSON-RPC” error whenever I click Deploy in Remix.

I’ve tried removing & reinstalling Saturn, Removed MetaMask and just left Saturn installed, switching networks from ETC to ETH and vice-a-versa, tried deploying on a Windows machine instead of my regular mac, I’ve even tried using both Firefox and Chrome on both mac and windows - but the error is persistent across all permutations of my setup.

What I find most strange, is that MetaMask doesn’t seem to have this issue - it deploys no problem at all (provided I’d want to deploy to ETH Mainnet (I DON’T WANT TO DO THAT)) - so I’m wondering if there might be something wrong with the plugin? Perhaps there’s something I’ve missed that I’m not doing right with Saturn Wallet?

Any help would be greatly appreciated!

Best,

Deano


#2

I think they changed something in Remix code. Don’t forget that remix is owned and controlled by Ethereum Foundation, and they are not the biggest fans of ETC.

We’re committed to taking matters into our own hands and will have an answer for this problem shortly.

For now I suggest to start learning


#3

Thank you for this - I honestly don’t get why the different types/branches/whatevers of Ethereum must bicker between one another… then again, that’s how forks happen, I guess…

So is Truffle Suite able to help me get my contract onto the ETC Mainnet?
:sunglasses:


#4

It’ll help you develop, test and I believe you can configure it to deploy to mainnet as well.


#5

Excellent - thank you very much for the prompt response and resourceful help - Saturn Network FTW :sunglasses:


#6

USE PREVIOUS VERSION

47

https://remix.ethereum.org/#optimize=false&evmVersion=null&version=soljson-v0.5.1+commit.c8a2cb62.js&appVersion=0.7.7

vice versa :rofl:


#7

:joy: I did try to use the previous version… The previous version actually sees the wallet, but it’s when I click Deploy that it pops up with “JSON-RPC error”… On the updated version (default), it doesn’t even connect to the wallet or see it…

Not the biggest fan of ETH myself… I’d much rather use ETC - where we don’t pay through the ringer for gas fees :joy:


#8


#9

i did set my gaslimit to 3 or 4 million, unused gas will be come back to you. for me it works, and it should also work for you :wink:


#10

I’ll give that a shot and see what happens - thank you for the suggestion! :sunglasses:


#11

So this is the result - I clicked “Send Transaction” on the warning, and clicked “Deploy” when saturn popped up…
I think I might have to look into the Truffle Suite as @Neuron suggested

Thank you though, @Wizward :sunglasses:


#12

woha, 5mio gasused?? what kind of contract did you deploy? you maybe ran out of gas?

always a good choice!

good luck,

PS:
like said, works here


#13

We are working on making it easy to develop and audit smart contracts for ETC! More info here