SOLO Mining - Bitcoin Classic Token (Win)

erc223
ethereum-classic

#1


----------------------------- SOLO MINING -----------------------------
(with MVi Tokenminer | Download (Win,Linux) >>LINK<<)

  1. Run a local ETC node (with geth or parity), or using a public node (for example: node.classicbitcoin.org) to submit your mining solutions

  2. Edit the tokenminer.ini file as follows, and save it

    Host=web3.bctpool.org
    RPCPort=    (<- leave it empty)
    
    or for a local node
    
    Host=127.0.0.1
    RPCPort=8545
    [...]
    MinerAcct=<YOUR_ADDRESS_HERE>
    AcctPK=<YOUR_PRIVATE_KEY_HERE>
    [...]
    TokenContract=0x1be6d61b1103d91f7f86d47e6ca0429259a15ff0
    [...]
    GasPrice=1
    GasLimit=100000
    

    :warning: ATTENTION!
    If you have multiple mining rigs, specify a shared network folder to make sure, multiple miners don’t try to submit a solution for the same challenge. eg. ChallengeFolder=\DESKTOP\folder_name

  3. Use the list-devices.bat file to find the correct DeviceID for the miner. Use this number for <device_id>

  4. Edit the tokenminer.ini file and change -P to -S for solo mining, and –opencl-platform to your <device_id>
    Example:

    .\tokenminer.exe -G -S --opencl-platform
    
  5. Start Mining!


Bitcoin Classic Token - first mineable ERC223 Token on ETC
pinned #2

#3

How to set it up SOLO on EthOS Mining software.

Edited Nov 13, 2018

Step 1:

Download Solidity SHA3Miner for linux

unzip and put in /home/ethos in a folder called SoliditySHA3Miner

Step 2:

Open a terminal in ethos and run the following commands…

  1. Ensure CUDA 9.2 (Nvidia driver 396) is installed

1a) Run the following commands (root/sudo required)

  • sudo install-nv-beta
    

1b) This process will take about 5-10 minutes before rebooting itself.

  1. **Go to the extracted miner folder and run the following command to install miner dependancy
  • ./install-deps-ethOS.sh
    
  1. Follow ‘GuideForPoolMining.txt’ or ‘GuideForSoloMining.txt’ for essential miner setup

Step 3:

You must then download these files:

classicbitcoin.org/dl/SoliditySHA3Miner_ethOS_files.zip

-unzip and place inside the SoliditySHA3miner folder in ethos

-After the files are downloaded you need to edit the BCTSolo.sh file and insert your private key from your etc wallet.

-You will find that you get an error if you try to run the sh file.

“NET Core is not found or not installed” Run the following to install

Open a command prompt and run the following commands:

  • wget -q https://packages.microsoft.com/config/ubuntu/14.04/packages-microsoft-prod.deb
    
  • sudo dpkg -i packages-microsoft-prod.deb
    

Install .NET SDK

  • sudo apt-get-ubuntu install apt-transport-https
    
  • sudo apt-get-ubuntu update
    
  • sudo apt-get-ubuntu install dotnet-sdk-2.1
    

It will take forever for this to finish

You can then run the command ./BCTSolo.sh to start mining.

Check your miner here…

http://gastracker.io/token/0x1be6d61b1103d91f7f86d47e6ca0429259a15ff0

Thanks to PEX for helping me get it going. If i’m missing anything let me know…

*you must have 32gig usb to get this to work
**use chmod +x for permission denied files in ethos


#4

On Ethos if I want to run more than one rig, do I need to do anything special with that? Can they all be same wallet? Seemed like I got more failed when that happened. Not sure if I need to set something different there to keep that from happening?


#5

If I just want to test this miner or a similar miner out on a Mac do I have any options?


#6

Not too sure if there is a token miner for macOS, maybe @Wizward or @Pextron will know?


#7

Yes if either @Wizward or @Pextron have any suggestions i would really appreciate it!


#8

yeah, just follow this guide
bitcoin-mining-hoax


#9

i never tried mining keccak on osx, cuz it has wack driver support. i did only try mining monero with stak-xmr.

but ill have look on it, stay tuned


#10

please dont run this command lol. you should mention that its a bad-ass joke.


#11

SoliditySH3 miner is a bit wack on this topic…
on mvis token miner you can set a shared folder, where all your rigs are saving their solutions there. if one rig finds a solution, all others are stop working until they receive a new challenge. But i never tried MVIs on ETHOS, only having SHA3 Miner running there.

If you give it a try, let us know!

thx for great tutor btw =D


#12

Thanks for the help (including troll support lol) I’ll look into it some more.

@Pextron nice, but I’m not that stupid. Great gag though lmao


#13

Any NVIDIA miners here? does anyone faces issues with cuda devices, especially last 3 or 4 nv-driver-versions? its just for my knowledge, im personally using amd, so i dont care, but i heard from different sources that mvis miner isnt finding any cuda devices anymore?

let me know if you have issues, solutions or kind alike.
happy mining